karma-chai-jquery

Chai Jquery for Karma

karma-chai-jquery

Chai-Jquery plugin for Karma Test Runner

This Karma plugin requires Karma ~0.10.0

To better align jQuery versions in build systems that depend on older versions of jQuery I've no longer bundled the most recent version of jQuery with karma-chai-jquery instead opting to offload that to a plugin like karma-jquery. The idea is that every karma plugin should do one thing and one thing only.

Install the module via npm

$ npm install --save-dev karma-chai-jquery
  • karma-chai-jquery requires jquery which is not included and recommended to be installed through karma-jquery.
  • karma-chai-jquery requires chai which is not included and recommended to be installed through karma-chai
module.exports = function(config) {
  'use strict';
  config.set({
    frameworks: ['mocha', 'chai', 'chai-jquery', 'jquery-1.8.3'],
    #...
  });
}

Usage for chai-jquery is fully outlined here.