Newly Potted Mandrakes

    jsdom-little

    0.10.6 • Public • Published

    Build Status

    WARNING: this fork is based on legacy jsdom version ~0.10.5.

    UPDATE: jsdom 4+ doesn't depend on contextify anymore however it no longer works with Node.js™ and instead requires io.js.

    jsdom-little

    Lightweight cut down version of jsdom.

    Removed dependencies:

    • contextify
    • xmlhttprequest
    • request

    Removed features:

    • Running JavaScript code in browser context
    • Fetching or processing external resources
    • Window
    • Events
    • XmlHttpRequest
    • Content of <style> nodes is not evaluated
    • jsdom.env works only as jsdom.env(html, level, callback) and returns {document: document}

    What it is good for?

    • You need something from jsdom (DOM, parsing, etc.) but full browser emulation is overkill.

    Keywords

    Install

    npm i jsdom-little

    DownloadsWeekly Downloads

    3,055

    Version

    0.10.6

    License

    MIT

    Last publish

    Collaborators

    • dorny