This package has been deprecated

Author message:

jest@26 ships with jsdom@16, so there is no reason to use this module

jest-environment-jsdom-sixteen

2.0.0 • Public • Published

jest-environment-jsdom-sixteen

Jest v26 ships with JSDOM@16, so no reason to use this package

Jest v25 by default uses JSDOM 15 to support Node 8. This package should also be compatible with Jest 24 and earlier.

This package comes with JSDOM v16, which also enables support for V8 code coverage.

If you need a newer JSDOM than the one that ships with Jest, install this package using npm install --save-dev jest-environment-jsdom-sixteen or yarn add jest-environment-jsdom-sixteen --dev, and edit your Jest config like so:

{
  "testEnvironment": "jest-environment-jsdom-sixteen"
}

Readme

Keywords

none

Package Sidebar

Install

npm i jest-environment-jsdom-sixteen

Weekly Downloads

96,036

Version

2.0.0

License

MIT

Unpacked Size

5.61 kB

Total Files

4

Last publish

Collaborators

  • simenb