Miss any of our Open RFC calls?Watch the recordings here! »

jest-environment-jsdom-fifteen

1.0.2 • Public • Published

jest-environment-jsdom-fifteen

Jest by default uses JSDOM 11 to support Node 6. This package uses JSDOM 15, which supports Node >= 8, and does not support Node 6 (and will therefore not be used in Jest any time soon).

If you need a newer JSDOM than the one that ships with Jest, install this package using npm install --save-dev jest-environment-jsdom-fifteen or yarn add jest-environment-jsdom-fifteen --dev, and edit your Jest config like so:

{
  "testEnvironment": "jest-environment-jsdom-fifteen"
}

If you would like to use JSDOM 14, see https://github.com/ianschmitz/jest-environment-jsdom-fourteen.

Keywords

none

Install

npm i jest-environment-jsdom-fifteen

DownloadsWeekly Downloads

218,208

Version

1.0.2

License

MIT

Unpacked Size

8.68 kB

Total Files

6

Last publish

Collaborators

  • avatar