inteobs

1.0.3 • Public • Published

inteobs

A ponyfill based on the w3c/IntersectionObserver polyfill

This module will help you get to use the goodness of Intersection Observer without affecting builtins.

The name is a playful contraction of Intersection Observer to inte-obs [ˈɪnˌtɛ-əbz] (first part in swedish meaning not - and then "obs" - so "not-observer").

Install

npm install inteobs

Usage

The default export of the package is either a reference to the native window.IntersectionObserver - or a js implementation of it:

import IntersectionObserver from "inteobs";

Caveats

One difference between this module and the official polyfill is that - due to being a ponyfill - a missing property in Edge 15 (isIntersecting) cannot be patched. However - the property in question is not at all essential for Intersection Observer to work (it can be worked around).

Credits

This module basically just exposes a repackaged w3c/IntersectionObserver - so any credit really has go to the great work done by its contributors :)

Package Sidebar

Install

npm i inteobs

Weekly Downloads

238

Version

1.0.3

License

ISC

Unpacked Size

14.1 kB

Total Files

3

Last publish

Collaborators

  • rasmusfl0e