Learn about our RFC process, Open RFC meetings & more.Join in the discussion! »

ilib-webpack-plugin2

0.9.1 • Public • Published

ilib-webpack-plugin2

ilib-webpack-plugin2 is a webpack plugin for ilib so that you can use ilib in your own webpack project and only include the ilib classes and locale data that you actually need. It can also be used to create a custom version of ilib, even if you are not using webpack in your own project.

To use iLib in your own project, you will need both the ilib-webpack-plugin2 and the ilib-webpack-loader together.

Be careful of the spelling of the repo name -- the enyojs project has a similarly-named "ilib-webpack-plugin" which is different and cannot be used with the ilb loader to build ilib, except if you are building it for Enyo or Enact.

The full documentation for the use of this plugin and the loader together is in the ilib-webpack-loader project.

Install

npm i ilib-webpack-plugin2

DownloadsWeekly Downloads

1

Version

0.9.1

License

Apache-2.0

Unpacked Size

33.9 kB

Total Files

4

Last publish

Collaborators

  • avatar