hypns-svelte-component

2.9.1 • Public • Published

HyPNS Svelte Component

Versions

'>= 2.80 Supports HyPNS v2.0'

'< 2.8.0 Supports HyPNS v1.0'

An open/close wrapper for HyPNS

npm i hypns-svelte-component

HyPNS uses @corestore/networker which has networking that needs to opened and closed intelligently.

When using HyPNS, you need to remember to

await HyPNS.close() // remembering things sucks, there's a better way! Let's use the computer

Instead of pushing this obligation out into userland, this handy little Svelte component wraps HyPNS with listeners that activate if:

Notes

The "svelte" entry in package.json needs to be empty for this to work. Otherwise things break...

TODO: Config the rollup to bundle alright even if "svelte" field is included.

Readme

Keywords

Package Sidebar

Install

npm i hypns-svelte-component

Weekly Downloads

2

Version

2.9.1

License

MIT

Unpacked Size

4.24 MB

Total Files

7

Last publish

Collaborators

  • douganderson444