Have opinions about JavaScript? We want to hear them. Take the 2018 JavaScript Ecosystem Survey »

hyperterm-1password

2.0.1 • Public • Published

1Password for HyperTerm

Extension for HyperTerm that adds 1Password integration.

1Password and HyperTerm in action

How to use

  1. Install HyperTerm
  2. Add hyperterm-1password to plugins in ~/.hyperterm.js.
  3. Use Cmd + \ to open the 1Password modal.

Configuring 1Password to work with HyperTerm

If you're using 1Password 5+, or you run into this screen:

Cannot Fill Item in Web Browser

This causes a problem for HyperTerm as it isn't a "trusted browser" per se. In order to fix this issue, you need to do the following:

  1. Open up 1Password's preferences
  2. Find the Advanced settings tab.
  3. Uncheck Verify browser code signature.

Uncheck "Verify browser code signature"

Configuring passwords in 1Password

So that 1Password automatically displays logins relevant to HyperTerm, add a website field to each login with a value of:

sudolikeaboss://local

This also ensures compatibility with the iTerm2 plugin, sudolikeaboss.

Adding website field to 1Password login item

Acknowledgements

A big thank you to Reuven V. Gonzales for his work on sudolikeaboss and the 1Password screenshots above. HyperTerm is largely based on sudolikeaboss.

Also a big thank you to AgileBits for bringing us 1Password.

install

npm i hyperterm-1password

Downloadsweekly downloads

15

version

2.0.1

license

MIT

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
Report a vulnerability