html-webpack-disable-plugin

    1.0.2 • Public • Published

    html-webpack-disable-plugin

    Disables html-webpack-plugin from emiting a file 😆

    Build Status Coverage Status npm version

    Installation

    You must be running Webpack on Node 4.x or higher. The plugin is available via npm:

    $ npm install  html-webpack-disable-plugin --save-dev

    Basic Usage

    Whenever you wish to supress the html-webpack-plugin from emmiting a html file, just add this plugin into your plugins list and boom. Done.

    const path = require('path');
    const HtmlWebpackPlugin = require('html-webpack-plugin');
    const HtmlDisablePlugin = require('html-webpack-disable-plugin');
     
    module.exports = {
        entry: './src/index.js',
     
        output: {
            path: path.join(process.cwd(), '.tmp/'),
            filename: 'emit-me-if-you-can.js',
        },
     
        plugins: [
            new HtmlWebpackPlugin(),
            new HtmlDisablePlugin()
        ],
    };

    If you've liked this, consider giving it a ⭐️!

    Licence

    MIT all the way. Let's create awesome stuff! 🚀

    Install

    npm i html-webpack-disable-plugin

    DownloadsWeekly Downloads

    1

    Version

    1.0.2

    License

    MIT

    Unpacked Size

    9.99 kB

    Total Files

    9

    Last publish

    Collaborators

    • husscode