Netherworld's Pretend Minibar

    gulp-emu
    TypeScript icon, indicating that this package has built-in type declarations

    2.1.0 • Public • Published

    gulp-emu

    gulp-emu is a gulp plugin for building ecmarkup specifications.

    Installation

    npm install gulp-emu
    

    NOTE: gulp-emu requires NodeJS 4.0 or greater.

    Usage

    var emu = require("gulp-emu");
    
    gulp.task("build", () => gulp.src("spec.html")
        .pipe(emu(options))
        .pipe(gulp.dest("out")));

    Options

    gulp-emu has the following options:

    • biblio <boolean> - Indicates whether to include {basename}.biblio.json in the output stream.
    • css <boolean> - Indicates whether to include elements.css in the output stream.
    • js <boolean> - Indicates whether to include menu.js and findLocalReferences.js in the output stream.
    • ecmarkup options

    Install

    npm i gulp-emu

    DownloadsWeekly Downloads

    24

    Version

    2.1.0

    License

    Apache-2.0

    Unpacked Size

    45.5 kB

    Total Files

    12

    Last publish

    Collaborators

    • rbuckton