NaNoWriMo Promotes Manuscription

    This package has been deprecated

    Author message:

    gulp-bandolero is deprecated. Please consider using gulp-rollup instead, or any other module.

    gulp-bandolero

    0.2.2 • Public • Published

    Gulp-bandolero.js

    gulp-bandolero is deprecated after esperanto. Please consider using another module like gulp-rollup for bundling your modules

    Another gulp plugin for resolving dependencies.

    This one is just wrap around esperanto.

    The idea is pretty simple: you write your modules using cool ECMAScript6 module syntax straight from the future, this little guy right there compiles it all to a single file module compatible with both CommonJS and AMD.

    Like so:

    var gulp   = require('gulp'),
        bundle = require('gulp-bandolero');
     
    gulp.task('js:build', function () {
        gulp.src('src/index.js')
            .pipe(bundle({name: 'steve'}))
            .pipe(gulp.dest('dst/'));
    });

    That's typeof it 😏

    Install

    npm i gulp-bandolero

    DownloadsWeekly Downloads

    2

    Version

    0.2.2

    License

    MIT

    Last publish

    Collaborators

    • dsblv