Node Promiscuous Modules

    This package has been deprecated

    Author message:

    WARNING: This project has been renamed to gulp-atom-electron. https://github.com/joaomoreno/gulp-atom-electron

    gulp-atom-shell

    0.10.0 • Public • Published

    gulp-atom-shell

    Build Status

    Usage

    var gulp = require('gulp');
    var atomshell = require('gulp-atom-shell');
     
    gulp.task('default', function () {
        return gulp.src('src/**')
            .pipe(atomshell({ 
                      version: '0.19.4',
                      platform: 'darwin'
             }))
            .pipe(atomshell.zfsdest('app.zip'));
    });

    Options

    You must provide the following options:

    The following options are optional:

    • token - GitHub access token(to avoid request limit. You can grab it here)

    • arch - the processor architecture (ia32, x64)

    • Windows

      • winIcon - path to an .ico file
      • companyName - company name
      • copyright - copyright statement
    • Darwin

      • darwinIcon - path to an .icns file
      • darwinBundleDocumentTypes - (reference) array of dictionaries, each containing the following structure:
      • name - the CFBundleTypeName value
      • role - the CFBundleTypeRole value
      • ostypes - the CFBundleTypeOSTypes value, a string array
      • extensions - the CFBundleTypeExtensions value, a string array of file extensions
      • iconFile - the CFBundleTypeIconFile value

    Install

    npm i gulp-atom-shell

    DownloadsWeekly Downloads

    12

    Version

    0.10.0

    License

    MIT

    Last publish

    Collaborators

    • joaomoreno