node package manager
Orgs are free. Discover, share, and reuse code in your team. Create a free org »

grunt-nw-builder

grunt-nw-builder NPM version Dependency Status

NPM

Let's you build your NW.js apps for osx, win, and linux with grunt. It will download the prebuilt binaries for a specify version, unpacks it, creates a release folder, create the app.nw file for a specified directory and copys the app.nw file where it belongs.

Issues with the output should be reported on the nw-builder issue tracker. Build Status

Getting Started

This plugin requires Grunt ~0.4.1

If you haven't used Grunt before, be sure to check out the Getting Started guide, as it explains how to create a Gruntfile as well as install and use Grunt plugins. Once you're familiar with that process, you may install this plugin with this command:

npm install grunt-nw-builder --save-dev

Once the plugin has been installed, it may be enabled inside your Gruntfile with this line of JavaScript:

grunt.loadNpmTasks('grunt-nw-builder');

The "nwjs" task

Usage Examples

grunt.initConfig({
  nwjs: {
    options: {
        platforms: ['win','osx'],
        buildDir: './webkitbuilds', // Where the build version of my NW.js app is saved 
    },
    src: ['./example/public/**/*'] // Your NW.js app 
  },
})

Options

Exactly the same as nw-builder. You have the advantage to configure the files via Grunt.

Manifest Options

platformOverrides

Just like nw-builder you can specify platform-specific manifest values.

{
    "name": "nw-demo",
    "version": "0.1.0",
    "main": "index.html",
    "window": {
        "frame": false,
        "toolbar": false
    },
    "platformOverrides": {
        "win": {
            "window": {
                "frame": true
            }
        }
    }
}

For more information see nw-builder's Manifest Options.

Troubleshooting

OSX ulimit

Darwin (OS X kernel) has a low limit for file descriptors (256 per process) by default, so you might get an EMFILE error or an error mentioning "too many open files" if youtry to open more file descriptors than this.

To get around it, run ulimit -n 1024 (or add it to your ~/.bash_profile). For more information, see henvic/osx-ulimit.

Release History

  • 2016-09-14 flavor option; you can now select any flavor of NW.js, not just sdk.
  • 2016-08-28 bumping nw-builder dependency to 3.0.0.
  • 2016-07-02 2.0.3 Fix for zip option plus some small nw-builder fixes.
  • 2016-07-02 2.0.2 Updated Grunt peer dependency
  • 2016-07-02 2.0.1 Supporting newer NW.js versions, alpha/beta builds, plus some other small fixes.
  • ...
  • 2014-12-12 1.0.0 64-bit support, improved platform-overrides and no more EMFILE errors. Also, macPlist CFBundleIdentifier is generated from package.json.
  • 2014-08-01 0.3.0 macPlist option improvements (see mllrsohn/nw-builder#96)
  • 2014-08-01 0.2.0 Moved logic into a separate module, config options will be backward compatible except keep_nw is no longer supported
  • 2013-09-19 Removed config merging (but kept the lookup for version number and name), added keep_nw option, fixed various small bugs.
  • 2013-09-09 fixed accidential deletion of nw.exe on windows builds, adding several improvements, opt in for timestamped builds, using version and name from package.json to name the build product and build dir, renamed download directory to cache, added merge from package.json options for nodewebkit (no need to add configuration to Gruntfile, but stays optional)
  • 2013-08-20 fix for the unzip lib
  • 2013-08-13 initial release