grunt-nsp-shrinkwrap

Grunt plugin for Node Security Project npm-shrinkwrap.json validation

grunt-nsp-shrinkwrap

Submits your npm-shrinkwrap.json file to the nodesecurity.io API for validation that dependencies or dependencies of dependencies are not vulnerable to known vulnerabilities.

Installation

$ npm install grunt-nsp-shrinkwrap --save-dev

Usage

Add this line to your project's grunt.js gruntfile:

grunt.loadNpmTasks('grunt-nsp-shrinkwrap');

Then use the task validate-shrinkwrap build tasks eg.

grunt.registerTask("default", 'validate-shrinkwrap');

License

MIT

Badges