grunt-html5-validate

    0.1.1 • Public • Published

    grunt-html5-validate

    A simpler, kinder Grunt plugin for Mozilla's HTML5 Linter.

    Getting Started

    This plugin requires Grunt.

    If you haven't used Grunt before, be sure to check out the Getting Started guide, as it explains how to create a Gruntfile as well as install and use Grunt plugins. Once you're familiar with that process, you may install this plugin with this command:

    npm install grunt-html5-validate --save-dev

    Once the plugin has been installed, it may be enabled inside your Gruntfile with this line of JavaScript:

    grunt.loadNpmTasks('grunt-html5-validate');

    The html5validate task

    In your project's Gruntfile, add a section named mozilla_html5_lint to the data object passed into grunt.initConfig().

    grunt.initConfig({
      html5validate: {
        src: 'dist/*.html',
      },
    })
     
    grunt.registerTask('default', ['html5validate']);

    Contributing

    In lieu of a formal styleguide, take care to maintain the existing coding style. Add unit tests for any new or changed functionality. Lint and test your code using Grunt.

    License

    Copyright (c) 2016 Ricardo Gladwell. Licensed under the MIT license.

    Install

    npm i grunt-html5-validate

    DownloadsWeekly Downloads

    0

    Version

    0.1.1

    License

    MIT

    Last publish

    Collaborators

    • rgladwell