npm: possibly marvellous

    glitchyscratch-i18n

    4.0.0 • Public • Published

    Glitchy Scratch I18N

    Localisation of all Glitchy Scratch components.

    Using glitchyscratch-i18n in development

    Installation

    You can install this package with NPM as a dev dependency-

    npm install --save-dev glitchyscratch-i18n

    or simply as a dependency with-

    npm install glitchyscratch-i18n

    . You can also use Yarn-

    yarn add glitchyscratch-i18n

    . Optionally, can also build it from source using Git-

    git clone https://github.com/Glitchy-Scratch/i18n.git
    cd i18n
    npm install
    

    .

    Basic Use

    import locales, {localeData, isRtl} from 'glitchyscratch-i18n';
    import editorMessages from 'glitchyscratch-i18n/locales/editor-messages';
    • locales: currently supported locales for the Scratch project
    • isRtl: function that returns true if the locale is one that is written right-to-left
    • localeData: locale data for the supported locales, in the format accepted by addLocaleData required by react-intl
    • editorMessages: the actual message strings for all supported locales for a particular resource. editorMessages collects all the strings for the interface, extensions and paint-editor.

    Keywords

    none

    Install

    npm i glitchyscratch-i18n

    DownloadsWeekly Downloads

    37

    Version

    4.0.0

    License

    BSD-3-Clause

    Unpacked Size

    13.4 MB

    Total Files

    314

    Last publish

    Collaborators

    • r4356th