node package manager

geos

GEOS (Geometry Engine) bindings for Node.

node-geos

GEOS (Geometry Engine) bindings for Node.

Required node version is 0.6.0 or higher. Make sure you have GEOS version 3.2.2 or higher installed together with the headers and libraries.

To obtain and build the bindings:

git clone git://github.com/kashif/node-geos.git
cd node-geos
node-gyp configure build
# npm install

or install it via npm:

npm install geos

or

npm install git://github.com/kashif/node-geos.git
npm test

To test the c++ binding we use vows. Just run vows on the tests in the test directory or use the above command. Make sure you have coffee-script installed as they are written in coffee-script.

As continuous integration system we use travis.

Build status:

For some examples please take a look at the examples directory.

Report bugs to http://github.com/kashif/node-geos/issues.