Nonsense Placement Mandatory
Have ideas to improve npm?Join in the discussion! »

generator-genesis-wordpress

0.2.7 • Public • Published

generator-wordpress

Yeoman generator for Genesis WordPress.

Dependencies

First install NodeJS v0.10, then Yeoman v1 & Bower v1.2.:

$ npm install -g yo bower

(You can check your versions by running node --version, npm --version, etc.)

Installation

Install Genesis WordPress Generator:

$ npm install generator-genesis-wordpress

If you get EMFILE issues, try running: ulimit -n 4096

Getting Started

If you haven't done so already, create & push your project to Github.

Run the Genesis WordPress Generator:

$ yo genesis-wordpress

Follow the prompts, and you'll have a working WordPress install!

Next, see the documentation for Genesis WordPress.**

Changelog

  • v0.2.7 – Always download requested WordPress version
  • v0.2.6 – Install pycurl
  • v0.2.5 – Install both python-software-properties and software-properties-common
  • v0.2.4 – Fix owner (deploy) for id_rsa & id_rsa.pub
  • v0.2.3 – Fix bug with copying id_rsa and id_rsa.pub
  • v0.2.2 – Use fs-extra to fix recursive copy issue
  • v0.2.1 – Remove Wrench because of bugs with overwriting existing folders
  • v0.2.0 – use Genesis WordPress#0.2.*
  • v0.1.7 – Add old.rb template
  • v0.1.6 – Use WP_ENV instead of Genesis::isDebug()
  • v0.1.5 – Use Genesis WordPress#0.1.*
  • v0.1.4 – Use existing deploy_to path on staging
  • v0.1.3 – Screw it. Reverted and just renamed any .-prefixed file
  • v0.1.1 – Add another .npmignore (isaacs/npm#1862)
  • v0.1.1 – Add .npmignore
  • v0.1.0 – Initial release

License

MIT License

Install

npm i [email protected]

Version

0.2.7

License

none

Last publish

Collaborators

  • avatar
  • avatar