This package has been deprecated

Author message:

This package is no longer actively maintained. Only security patches will be provided, if needed. Consider switching to fp-ts.

folktale

2.3.2 • Public • Published

Folktale

Ready to work on~! Chat on Gitter Build status Coverage Status NPM version Dependencies status Licence

Folktale is a standard library for functional programming in JavaScript.

Installing

Folktale can be installed through npm:

$ npm install folktale

Not using Node.js? Check out our guide to running Folktale in other environments!

Documentation

If you find any functionality that's not documented, or whose documentation is confusing or hard to understand, please report a bug on our issue tracker

Supported platforms

Folktale is written for ECMAScript 2015 platforms, but it uses a subset of features that can be safely backported to platforms as old as ECMAScript 3. If you're running your program in an older platform, you'll need es5-shim and es6-shim.

Browsers:

  • Chrome 36+
  • Firefox 21+
  • Safari 6+
  • Internet Explorer 9+
  • Edge 13+
  • Opera 12.12+

Mobile browsers:

  • Android 4.4+
  • iOS 8.3+

Support

Note that all interactions in this project are subject to Origami Tower's Code of Conduct.

Having trouble using Folktale?
Think Folktale should do something it doesn't yet?

By submitting a Pull Request you agree with releasing your code under the MIT licence.

Folktale discussion channels and information

Licence

Folktale is copyright (c) Quildreen Motta 2015-2017, and released under the MIT licence. See the LICENCE file in this repository for detailed information.

Package Sidebar

Install

npm i folktale

Weekly Downloads

37,033

Version

2.3.2

License

MIT

Unpacked Size

652 kB

Total Files

168

Last publish

Collaborators

  • robotlolita