Null Pointer Micromanagement

    flow-require

    0.0.1 • Public • Published

    flow-require

    use .flow.js extension

    How to use

    # use
    require('flow-require')()
     
    # use your react-tools option
    require('flow-require')({
      harmony: true,
        sourceMap: true,
        sourceFilename: 'source.js',
      stripTypes: true
    })

    Default Option is {harmony: true, stripTypes: true}

    See transform options here https://www.npmjs.org/package/react-tools

    Example

    a.flow.js

    /* @flow */
    module.exports = class A {}

    main.js

    require('flow-require')()
    require('./a')

    Keywords

    none

    Install

    npm i flow-require

    DownloadsWeekly Downloads

    0

    Version

    0.0.1

    License

    ISC

    Last publish

    Collaborators

    • mizchi