Have ideas to improve npm?Join in the discussion! »

fis3-parser-dart-sass

2.2.4 • Public • Published

fis3-parser-dart-sass

A fis plugin to parse sass with dart-sass.

styled with prettier npm npm npm

install

npm install --global fis3-parser-dart-sass

usage

// fis-conf.js

const sassConf = {
  outputStyle: 'expanded',
  sourceMapContents: true,
  sourceMap: false,
  omitSourceMapUrl: false
}

fis.match('*.{sass,scss}', {
  parser: fis.plugin('dart-sass', sassConf);
});

more options: https://github.com/sass/dart-sass

default options

{
  "outputStyle": "expanded",
  "sourceMapContents": true,
  "sourceMap": false,
  "omitSourceMapUrl": false
}

NOTICE: this might change in future

links

license

MIT © fisker Cheung

Install

npm i fis3-parser-dart-sass

DownloadsWeekly Downloads

69

Version

2.2.4

License

MIT

Unpacked Size

116 kB

Total Files

4

Last publish

Collaborators

  • avatar