Have ideas to improve npm?Join in the discussion! »

    fis3-lint-eslint-noisy

    4.0.16 • Public • Published

    fis3-lint-eslint-noisy

    a js linter plugin of fis3 based on eslint.

    styled with prettier npm npm npm

    install

    npm install --global fis3-lint-eslint-noisy

    about package name

    i named this package noisy is because the other eslint plugins for fis all silently failed when error report by eslint.

    usage

    // fis-conf.js
    
    const eslintConf = {}
    
    fis.match('*.js', {
      lint: fis.plugin('eslint-noisy', eslintConf),
    })

    options

    options: http://eslint.org/docs/developer-guide/nodejs-api#cliengine

    rules and fixable rules: http://eslint.org/docs/rules/

    const eslintConf = {
      fix: true, // ❗!!! important !!!❗
             // default: true,
             // be careful, this might change your source code
             // this will trigger `CLIEngine.outputFixes` automatically
      configFile:
      envs: // default: ['browser']
      extensions:
      globals:
      ignore:
      ignorePath:
      ignorePattern:
      baseConfig:
      rulePaths:
      rules:
      useEslintrc: // defalut: true
      parser:
      cache:
      cacheFile:
      cacheLocation:
      cwd:
    };

    default options

    {
      "envs": ["browser"],
      "fix": true,
      "useEslintrc": true
    }

    NOTICE: this might change in future

    links

    license

    MIT © fisker Cheung

    Install

    npm i fis3-lint-eslint-noisy

    DownloadsWeekly Downloads

    22

    Version

    4.0.16

    License

    MIT

    Unpacked Size

    5.31 kB

    Total Files

    4

    Last publish

    Collaborators

    • avatar