node package manager
Easy sharing. Manage teams and permissions with one click. Create a free org »

fis-postprocessor-postcss

fis-postprocessor-postcss

fis 的 postcss 插件。 内置 cssnextautoprefixer

使用

安装

npm i fis-postprocessor-postcss -g

配置

fis.config.merge({
    modules: {
        postprocessor : {
            css: 'postcss'
        }
    }
});

参数

settings: {
    postprocessor: {
        postcss: {
            autoprefixer: false, // 默认 true 
            cssnext: false, // 默认 false 
            customPlugin: function(plugins) {   // 参数 plugins 是内置插件 
                plugins = plugins.push(require('postcss-border'));
                return plugins; // 返回新的插件列表 
            }
        }
    }
}

demo 说明

安装完插件后,切换至 demo/src 目录下执行:

fis release -d dev [-mD]

关于 cssnext

目前还不能和 sass 混用,即 '.scss' 文件中不要掺杂 cssnext 语法。

关于 cssgrace

在 fis postprocessor 中, cssgrace 处理图片路径有问题,不建议使用。