fill-pdf
    DefinitelyTyped icon, indicating that this package has TypeScript declarations provided by the separate @types/fill-pdf package

    1.1.0 • Public • Published

    fill-pdf

    Build Status

    A node module to fill out PDF forms (utf8 compatible).

    It uses pdftk to fill out PDF forms.

    Installation

    npm install fill-pdf
    

    Dependencies

    You need to have the pdftk binary in your PATH.

    Install on Mac OSX

    Install on Ubuntu

    sudo apt-get install pdftk

    Usage example (with express)

    var fillPdf = require("fill-pdf");
    var formDate = { FieldName: 'Text to put into form field' };
    var pdfTemplatePath = "templates.pdf";
     
    app.get('/filled_form.pdf', function(req, res) {
      fillPdf.generatePdf(formData, pdfTemplatePath, function(err, output) {
        if ( !err ) {
          res.type("application/pdf");
          res.send(output);
        }
      });
    });

    Acknowledgements

    Based on utf8-fdf-generator

    Install

    npm i fill-pdf

    DownloadsWeekly Downloads

    1,818

    Version

    1.1.0

    License

    MIT

    Last publish

    Collaborators

    • dommmmel
    • scottsoneal