npm

Bring the best of OSS JavaScript development to your projects with npm Orgs - private packages & team management tools.Learn more »

ffmpeg-splice

0.1.0 • Public • Published

ffmpeg-splice

Splice videos with ffmpeg

 
require('ffmpeg-splice')({
 
  input: 'video.avi',
  splices: [
    {
      start: 10 * 1000,
      duration: 10 * 1000,
    },{
      start: 30 * 1000,
      duration: 5 * 1000,
    }
  ],
  output: 'spliced_video.avi', // will be the concatenation
                               // of the specified segments.
  tmpFolder: '/tmp',
 
}, function(err) {
 
  if(err) console.log(err)
  else console.log('done')
 
})
 

You need ffmpeg up and running to use this module.

install

npm i ffmpeg-splice

Downloadsweekly downloads

0

version

0.1.0

license

MIT

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
Report a vulnerability