expo-gl
TypeScript icon, indicating that this package has built-in type declarations

13.6.0 • Public • Published

expo-gl

Provides GLView that acts as OpenGL ES render target and gives GL context object implementing WebGL 2.0 specification.

API documentation

Installation in managed Expo projects

For managed Expo projects, please follow the installation instructions in the API documentation for the latest stable release.

Installation in bare React Native projects

For bare React Native projects, you must ensure that you have installed and configured the expo package before continuing.

Add the package to your npm dependencies

npx expo install expo-gl

Compatibility

To use version 11.2.0 or newer of expo-gl you will need to use at least version 0.68.0 of React Native.

expo-gl react-native
<=8.x.x *
>=9.0.0 && <11.2.0 >=0.63.1 && <0.65.0
>=11.2.0 >=0.68.0

To use reanimated worklets you will need compatible version of react-native-reanimated.

expo-gl react-native-reanimated
<11.3.0 <=2.8.0
>=11.3.0 >2.8.0

Configure for iOS

Run npx pod-install after installing the npm package.

Configure for Android

No additional set up necessary.

Contributing

Contributions are very welcome! Please refer to guidelines described in the contributing guide.

Package Sidebar

Install

npm i expo-gl

Weekly Downloads

7,901

Version

13.6.0

License

MIT

Unpacked Size

610 kB

Total Files

101

Last publish

Collaborators

  • radoslawkrzemien
  • pkham
  • szdziedzic
  • tsapeta
  • wkozyra
  • ide
  • lukmccall
  • alanhughes
  • kadikraman
  • aleqsio
  • marklawlor
  • gabrieldonadel
  • simek
  • keith-kurak
  • christopherwalter
  • kbrandwijk
  • fiber-god
  • brentvatne
  • evanbacon
  • quinlanj
  • expoadmin
  • exponent
  • wschurman
  • bycedric
  • jonsamp
  • princefleaswallow
  • kudochien
  • ccheever
  • jesseruder
  • terribleben
  • sjchmiela
  • esamelson