Nonsense Placement Mandatory

    eslint-plugin-wyze

    3.4.0 • Public • Published

    eslint-plugin-wyze

    Build Status npm devDependencies

    My personal ESLint rules.

    Installation

    There is a peerDependencies on eslint.

    $ npm i --save-dev eslint-plugin-wyze eslint

    Usage

    package.json

    {
      // ...
      "eslintConfig": {
        "plugins": [
          "wyze"
        ]
      }
    }

    .eslintrc

    {
      "plugins": [
        "wyze"
      ]
    }

    Supported Rules

    Recommended Config

    We support a recommended config for the rules.

    Enable

    {
      "extends": "plugin:wyze/recommended",
      "plugins": [
        "wyze"
      ]
    }

    Rules

    {
      "rules": {
        "wyze/func-call-arg-spacing": "error",
        "wyze/func-params-spacing": "error",
        "wyze/max-file-length": "error",
        "wyze/newline-after-export": "error",
        "wyze/sort-destructuring-keys": "error",
        "wyze/sort-imports": "error",
        "wyze/space-around-conditional": "error"
      }
    }

    Change Log

    Full Change Log

    v3.4.0 (2018-07-11)

    • [409135348d] - Fix sort-imports auto-fix with TypeScript parser (#24) (Justin Anastos)
    • [ef1fb7b259] - Add support for default values (#21) (Jakub Rożek)
    • [aea583cbd3] - Update code to reflect new lint rules (Neil Kistner)
    • [8281a343f7] - Upgrade dependencies and remove prelint command (Neil Kistner)
    • [18ec073bf2] - Drop support for Node 4 (Neil Kistner)

    License

    MIT © Neil Kistner

    Install

    npm i eslint-plugin-wyze

    DownloadsWeekly Downloads

    496

    Version

    3.4.0

    License

    MIT

    Unpacked Size

    263 kB

    Total Files

    43

    Last publish

    Collaborators

    • wyze