Negatory. Postpone Mission.

    eslint-plugin-ts-exports

    1.2.5 • Public • Published

    ESLint wrapper for ts-prune

    Installation

    This plugin requires your project to use TypeScript (>=4.1.3).

    yarn add eslint-plugin-ts-exports --dev

    Example Configuration

    The plugin relies on TypeScript compiler services to resolve types. You need to set your tsconfig.json file in your eslint configuration via parserOptions.

    {
      "plugins": ["ts-exports"],
      "parserOptions": {
        "project": "./tsconfig.json"
      },
      "rules": {
        "ts-exports/unused-exports": 2,
      }
    }

    Rules

    Keywords

    none

    Install

    npm i eslint-plugin-ts-exports

    DownloadsWeekly Downloads

    56

    Version

    1.2.5

    License

    MIT

    Unpacked Size

    6.85 kB

    Total Files

    5

    Last publish

    Collaborators

    • wcandillon