eslint-plugin-strict-vue

1.0.0 • Public • Published

eslint-plugin-strict-vue

NPM version

Various ESLint rules to make you Vue(x) code a bit stricter

🥋 Requirements

  • ESLint >=4.15.0
  • Node.js >=8.0.0

🏋 Installation

$ npm i eslint eslint-plugin-strict-vue --save-dev

🤹‍ Usage

Configure it in .eslintrc or package.json:

{
    "name": "my-awesome-project",
    "eslintConfig": {
        "parserOptions": {
            "ecmaVersion": 2018,
            "sourceType": "module"
        },
        "plugins": [
            "strict-vue"
        ],
        "rules": {
            "strict-vue/require-jsdoc": "error",
            "strict-vue/no-root-store-calls": "error",
            "strict-vue/no-root-store-assets": "error",
        }
    }
}

🎭 Rules

License

MIT

Package Sidebar

Install

npm i eslint-plugin-strict-vue

Weekly Downloads

324

Version

1.0.0

License

MIT

Unpacked Size

37.8 kB

Total Files

24

Last publish

Collaborators

  • glebkaf