Newsworthy Presidential Mistakes

    eslint-plugin-packages

    1.1.2 • Public • Published

    eslint-plugin-packages Build Status

    Manage your monorepo with eslint

    Rules

    module-boundary:

    • Cannot reach into top-level @app packages
    • Cannot import from the same package

    module-boundary

    This rule will check all import/require to ensure it does not reach into a top-level packages folder

    Valid

    import { actionCreators } from "@app/thread";

    Invalid

    import { actionCreators } from "@app/thread/message";

    circular-imports

    Valid

    // ./packages/mail/something.js
    import { actionCreators } from "@app/thread";

    Invalid

    // ./packages/thread/something.js
    import { actionCreators } from "@app/thread";

    Install

    npm i eslint-plugin-packages

    DownloadsWeekly Downloads

    151

    Version

    1.1.2

    License

    MIT

    Unpacked Size

    9.83 kB

    Total Files

    10

    Last publish

    Collaborators

    • neurosnap