eslint-plugin-noredink-cypress

0.3.0 • Public • Published

eslint-plugin-noredink-cypress

An ESLint Plugin with additional rules we use in our Cypress test files.

Installation

You'll first need to install ESLint:

$ npm i eslint --save-dev

Next, install eslint-plugin-noredink-cypress:

$ npm install eslint-plugin-noredink-cypress --save-dev

Note: If you installed ESLint globally (using the -g flag) then you must also install eslint-plugin-cypress-percy globally.

Usage

Add noredink-cypress to the plugins section of your .eslintrc configuration file. You can omit the eslint-plugin- prefix:

{
    "plugins": [
        "noredink-cypress"
    ]
}

Then configure the rules you want to use under the rules section.

{
    "rules": {
        "noredink-cypress/assertion-before-command": ["error", {commandsToCheck: ["percySnapshot", "snapshot", "asdf"]}]
    }
}

Supported Rules

Rule Description
assertion-before-command Ensure that certain Cypress commands (such as cy.percySnapshot) are always preceded by an assertion or a call to function (which may or may not contain an assertion, that isn't checked)

Development

You can test this plugin locally with npm run test.

Package Sidebar

Install

npm i eslint-plugin-noredink-cypress

Weekly Downloads

0

Version

0.3.0

License

ISC

Unpacked Size

8.87 kB

Total Files

5

Last publish

Collaborators

  • noredink-user