Have ideas to improve npm?Join in the discussion! »

eslint-plugin-module-resolver

0.11.0 • Public • Published

eslint-plugin-module-resolver

npm version Build Status

Warn when using relative paths to modules aliased using babel-plugin-module-resolver

Installation

You'll first need to install ESLint:

$ yarn add --dev eslint

Next, install eslint-plugin-module-resolver:

$ yarn add --dev eslint-plugin-module-resolver

Usage

Add module-resolver to the plugins section of your .eslintrc configuration file. You can omit the eslint-plugin- prefix:

{
    "plugins": [
        "module-resolver"
    ]
}

Then configure the rules you want to use under the rules section.

{
    "rules": {
        "module-resolver/use-alias": 2
    }
}

Supported Rules

License

ESLint-plugin-module-resolver is licensed under the MIT License.

Install

npm i [email protected]

Version

0.11.0

License

MIT

Unpacked Size

3.46 kB

Total Files

3

Last publish

Collaborators

  • avatar