Neocon Propaganda Machine

    This package has been deprecated

    Author message:

    Package no longer supported. Contact Support at https://www.npmjs.com/support for more info.

    eslint-plugin-closuredepth

    1.0.2 • Public • Published

    eslint-plugin-closuredepth

    This project is no longer maintained

    Eslint plugin in order to provide warnings closure depth, and you can avoid the associated performance penalties

    Installation

    Install ESLint either locally or globally.

    $ npm install eslint

    If you installed ESLint globally, you have to install the closuredepth plugin globally too. Otherwise, install it locally.

    $ npm install eslint-plugin-closuredepth

    Configuration

    Add plugins section and specify ESLint-plugin-closuredepth as a plugin.

    {
      "plugins": [
        "closuredepth"
      ]
    }

    Add the rule, where 'limit' is your desired maximum depth

    {
      "rules": {
        "closuredepth/closuredepth": [ 2, { "limit": 3 } ]
      }
    }

    License

    ESLint-plugin-closuredepth is licensed under the MIT License.

    Install

    npm i eslint-plugin-closuredepth

    DownloadsWeekly Downloads

    0

    Version

    1.0.2

    License

    MIT

    Unpacked Size

    4.64 kB

    Total Files

    6

    Last publish

    Collaborators

    • peteward44