eslint-config-tram-one

    4.0.0 • Public • Published

    eslint-config-tram-one

    This is the eslint config (used in tandem with xo) for the Tram-One Project

    This config is supposed to be useful for both frameworks written for Tram-One, and web-apps using Tram-One.

    Installation and Usage

    First install xo and the lint config:

    npm install --save-dev xo eslint-config-tram-one

    Then, add the following to your package.json under scripts:

    "lint""xo"

    and add the following at the end of the package.json:

    "xo"{
      "extends": [
        "tram-one"
      ]
    }

    Finally, to use, run:

    npm run lint

    Install

    npm i eslint-config-tram-one

    DownloadsWeekly Downloads

    2

    Version

    4.0.0

    License

    MIT

    Unpacked Size

    4.09 kB

    Total Files

    4

    Last publish

    Collaborators

    • jrjurman