This package has been deprecated

    Author message:

    This package is not maintained anymore. Use either eslint-config-rg-node or eslint-config-rg-react

    eslint-config-researchgate-base

    3.0.0 • Public • Published

    eslint-config-researchgate

    npm version

    This package provides ResearchGate's .eslintrc as an extensible shared config.

    Usage

    We export three ESLint configurations for your usage.

    eslint-config-researchgate

    Our default export contains all of our ESLint rules, including EcmaScript 6+ and React. It requires eslint and eslint-plugin-react.

    1. npm install --save-dev eslint-config-researchgate eslint-plugin-react eslint
    2. add "extends": "researchgate" to your .eslintrc

    eslint-config-researchgate/base

    Lints ES6+ but does not lint React. Requires eslint.

    1. npm install --save-dev eslint-config-researchgate eslint
    2. add "extends": "researchgate/base" to your .eslintrc

    eslint-config-researchgate/legacy

    Lints ES5 and below. Only requires eslint.

    1. npm install --save-dev eslint-config-researchgate eslint
    2. add "extends": "researchgate/legacy" to your .eslintrc

    See ResearchGate's Javascript styleguide and the ESlint config docs for more information.

    Improving this config

    Consider adding test cases if you're making complicated rules changes, like anything involving regexes. Perhaps in a distant future, we could use literate programming to structure our README as test cases for our .eslintrc?

    You can run tests with npm test.

    You can make sure this module lints with itself using npm run lint.

    Install

    npm i eslint-config-researchgate-base

    DownloadsWeekly Downloads

    0

    Version

    3.0.0

    License

    MIT

    Last publish

    Collaborators

    • mdio
    • stefanhoth
    • roche_rg
    • koga_rg
    • ko
    • and
    • haeusler
    • olexiyk
    • researchgate-bot
    • danez