Nightly Panic Munchies

    eslint-config-reducer

    0.6.0 • Public • Published

    eslint-config-reducer

    npm version npm

    ESLint config with Prettier for Vanilla Javascript and ReactJS

    Install

    $ npm i -D eslint eslint-config-reducer prettier

    Use

    To use eslint-config-reducer, add it to your .eslintrc file

    For Node/JavaScript project

    {
      "extends": "reducer",
      "rules": {}
    }

    For ReactJS project

    {
      "extends": "reducer/react",
      "rules": {}
    }

    For ReactJS + TypeScript project

    {
      "extends": "reducer/typescript",
      "rules": {}
    }

    Install

    npm i eslint-config-reducer

    DownloadsWeekly Downloads

    9

    Version

    0.6.0

    License

    MIT

    Unpacked Size

    4.89 kB

    Total Files

    9

    Last publish

    Collaborators

    • dnshi