Miss any of our Open RFC calls?Watch the recordings here! »

eslint-config-metamo

0.2.10 • Public • Published

eslint-config-metamo

ESlint + Prettier のルールセット

使える: React (Next.js), Vue, Nuxt
不明: node, TS

Install

npm install -D eslint-config-metamo eslint prettier

Usage

.eslintrc

{
  "extends": ["eslint-config-metamo"]
}

TypeScript

{
  "extends": ["eslint-config-metamo","eslint-config-metamo/ts"]
}

Vue + TypeScript

{
  "extends": ["eslint-config-metamo/vue"]
}

Nuxt + TypeScript

{
  "extends": ["eslint-config-metamo/nuxt"]
}

React + TypeScript

{
  "extends": ["eslint-config-metamo/react"]
}

Install

npm i eslint-config-metamo

DownloadsWeekly Downloads

30

Version

0.2.10

License

MIT

Unpacked Size

16.1 kB

Total Files

22

Last publish

Collaborators

  • avatar