eslint-config-hubspot

7.4.1 • Public • Published

eslint-config-hubspot

npm version

HubSpot's ESLint configurations

Install

// npm
$ npm install --save-dev eslint eslint-config-hubspot eslint-plugin-react

// yarn
$ yarn add eslint eslint-config-hubspot eslint-plugin-react --dev

For the esnext version or if you are using newer syntax, you'll also need Babel's ESLint parser:

//npm
$ npm install --save-dev babel-eslint

// yarn
$ yarn add babel-eslint --dev

This will let you use ES2016 features like async/await and decorators. For a full list of features see Babel's experimental features and their Learn ES2015.

Usage

Add ESLint configurations to your package.json:

{
  "eslintConfig": {
    "extends": "hubspot" // or "hubspot/esnext"
  }
}

Or .eslintrc*:

{
  "extends": "hubspot" // or "hubspot/esnext"
}

License

MIT © HubSpot

Package Sidebar

Install

npm i eslint-config-hubspot

Weekly Downloads

68

Version

7.4.1

License

MIT

Last publish

Collaborators

  • henryqdineen
  • maxwellskala
  • arota-hubspot
  • service-ccs
  • rberdeen-hubspot
  • also
  • kj800x
  • friss
  • jhilker
  • geekjuice