eslint-config-belsrc

    1.1.2 • Public • Published

    eslint-config-belsrc

    Last Commit

    An opinionated collection of ESLint plugin configs I use in other projects.

    • eslint-plugin-fp
    • eslint-plugin-import
    • eslint-plugin-promise
    • eslint-plugin-react
    • eslint-plugin-vue

    Install

    npm i -D eslint-config-belsrc

    Use

    // .eslintrc.js
    module.exports = {
      extends: ['eslint-config-belsrc'],
    };

    The package also contains a usable prettier config.

    // .prettierrc.js
    const config = require('eslint-config-belsrc/.prettierrc');
     
    module.exports = config;

    TODO

    • add eslint-plugin-jsx-a11y
    • add eslint-plugin-jest
    • add eslint-plugin-security (is it maintained enough to use?)

    Peer Dependencies

    • eslint: >= 5.2.0 & < 6
    • prettier: >=1.14.0 & < 2
    • babel-eslint: >=10.0.0 & < 11

    LICENCE

    MIT

    Install

    npm i eslint-config-belsrc

    DownloadsWeekly Downloads

    2

    Version

    1.1.2

    License

    MIT

    Unpacked Size

    16.9 kB

    Total Files

    6

    Last publish

    Collaborators

    • belsrc