error-patch

    0.0.5 • Public • Published

    ⚠️ ERROR PATCH!

    Patch all error classes so that you can run them through a callback before throwing.

    Usage

    const errorPatch = require(`error-patch`)
     
    errorPatch(error => {
      // handle the error object
      someLoggerFunction(error)
    })
     
    throw new Error('ERRRRORRRRR!!!')

    Install

    npm i error-patch

    DownloadsWeekly Downloads

    0

    Version

    0.0.5

    License

    MIT

    Last publish

    Collaborators

    • garbles