Miss any of our Open RFC calls?Watch the recordings here! »

error-overlay-webpack-plugin

0.4.1 • Public • Published

Error Overlay Webpack Plugin

Build Status version MIT License

Catch errors with style 💥✨

This plugin will display an error overlay in your application. It is the same error overlay used in create-react-app.

  • 📦 Webpack 4 support
  • 🥞 Elegant stack trace
  • 📝 Click to open error line in editor
Error Overlay Webpack Plugin Example
npm install error-overlay-webpack-plugin --save-dev

Usage

// webpack.config.js
const ErrorOverlayPlugin = require('error-overlay-webpack-plugin')
 
module.exports = {
  entry: 'main.js',
  output: {
    path: __dirname + '/dist',
    filename: 'bundle.js',
  },
  plugins: [new ErrorOverlayPlugin()],
  devtool: 'cheap-module-source-map', // 'eval' is not supported by error-overlay-webpack-plugin
}

License

MIT

Install

npm i error-overlay-webpack-plugin

DownloadsWeekly Downloads

20,250

Version

0.4.1

License

MIT

Unpacked Size

16.2 kB

Total Files

8

Last publish

Collaborators

  • avatar