ember-noscript

    4.1.0 • Public • Published

    ember-noscript

    Build Status Ember Observer Score

    Compatibility

    • Ember.js v3.4 or above
    • Ember CLI v2.13 or above
    • Node.js v8 or above

    Installation

    Only does one thing, hopefully well:

    <noscript>
      <p>
        For full functionality of this site it is necessary to enable JavaScript.  
        Here are the
        <a href='https://www.enable-javascript.com/' target='_blank'> instructions how to enable JavaScript in your web browser</a>.
      </p>
    </noscript>

    Usage

    • ember install ember-noscript

    Customization

    This addon is configured via your applications config/environment.js file.

    The default noScript value is:

      noScript: {
        'content': "<p>" +
                    "For full functionality of this site it is necessary to enable JavaScript." +
                    "Here are the <a href='https://www.enable-javascript.com/' target='_blank'>" +
                    "instructions on how to enable JavaScript in your web browser</a>." +
                  "</p>",
        'placeIn': 'head'
      }

    See the Contributing guide for details.

    License

    This project is licensed under the MIT License.

    Install

    npm i ember-noscript

    DownloadsWeekly Downloads

    242

    Version

    4.1.0

    License

    MIT

    Unpacked Size

    7.58 kB

    Total Files

    8

    Last publish

    Collaborators

    • jrjohnson