Nine Pedestrians Mesmerized

    This package has been deprecated

    Author message:

    Package no longer supported. Contact Support at https://www.npmjs.com/support for more info.

    eleventy-plugin-sass

    1.2.0 • Public • Published

    eleventy-plugin-sass

    A plugin that adds Sass support to Eleventy

    Installation

    Available on npm.

    npm install eleventy-plugin-sass --save
    

    Open up your Eleventy config file (probably .eleventy.js) and use addPlugin:

    const pluginSass = require("eleventy-plugin-sass");
    module.exports = function(eleventyConfig) {
      eleventyConfig.addPlugin(pluginSass, sassPluginOptions);
    };
    

    Read more about Eleventy plugins.

    Options

    Key Type Default description
    watch glob or array of globs ['**/*.{scss,sass}', '!node_modules/**'] The sass files you wish to compile (and watch when you serve)
    sourcemaps Boolean false Add sourcemaps next to your sass files
    cleanCSS Boolean true Runs the css trough cleanCSS
    cleanCSSOptions Object N/A Options to pass to cleanCSS
    autoprefixer Boolean true Adds browser specific prefixes if needed (adheres to BrowserList)
    outputDir String undefined specifies the desired output directory
    remap Boolean false toggles the way EPS handles the output or better omits the path-part of each parsed file, so that you might get a slightly cleaner output
    sassOptions Object N/A Options you want to pass to node-sass

    Disclaimer

    This plugins wraps around internal Eleventy code, so if they changes their way of working it might stop working.

    Contributing

    Please do contribute, I am open to any changes. Just clone the repository and open a pull request.

    License

    MIT © Maarten Schroeven

    Install

    npm i eleventy-plugin-sass

    DownloadsWeekly Downloads

    172

    Version

    1.2.0

    License

    MIT

    Unpacked Size

    9.26 kB

    Total Files

    5

    Last publish

    Collaborators

    • sonaryr