eleventy-plugin-postcss

1.0.4 • Public • Published

Eleventy plugin for Postcss

A small plugin for @11ty/eventy that enables the support for PostCSS pre-processor in you eleventy project.

Requirements

  • @11ty/eleventy@^1.0.0

Features

  • 😌 Simple. Easy to install, requires minimum configuration.
  • ⭐️ Modern. Compatible with the most recent major eleventy version.
  • 🗂 Seamless. Supports the following file extensions: .css, .postcss, .pcss.
  • ⚙️ Configurable. Supports PostCSS configuration via .postcssrc file.

Usage

  1. Install: npm install --save-dev eleventy-plugin-postcss
  2. Add the following lines to the .eleventy.js:
// Import the plugin
const PostCSSPlugin = require("eleventy-plugin-postcss");

module.exports = (config) => {
    // Enable the plugin in you project
    config.addPlugin(PostCSSPlugin);
}
  1. (Optional) Create a .postcssrc.{json,yml} config file for additional configuration.

Contribute

Feel free to open a Github issue for suggestions, bug reports, feature requirements.

Package Sidebar

Install

npm i eleventy-plugin-postcss

Weekly Downloads

473

Version

1.0.4

License

ISC

Unpacked Size

4.89 kB

Total Files

6

Last publish

Collaborators

  • pewstiepoll