node package manager

electron-react-scaffold

Electron React Scaffold

Dependencies DevDependencies

Requirements

node -v
v5.1.1
 
electron -v
v0.36.0

Start

npm install
npm install -g electron-prebuilt
 
// or if you have installed electron-prebuilt
 
npm update -g electron-prebuilt

Debug

npm start

Dev Build (only darwin)

npm run dist

Production Build (All Platforms)

npm run build
 
// target: ./dist/

Using electron-packager.

Contributors

License

The MIT License (MIT)