discord.io
    TypeScript icon, indicating that this package has built-in type declarations

    2.5.3 • Public • Published

    discord.io

    A small, single-file, fully featured Discordapp library for Node.js and browsers.

    Discord NPM

    Requirements

    Required:

    • Node.js 0.10.x or greater
    • Web Browser if not using Node.js

    Optional:

    • Audio
      • Node.js 0.12.x
      • ffmpeg/avconv (needs to be added to PATH)

    Documentation / Gitbooks

    Getting Started:

    Installing

    Stable npm install discord.io

    Latest npm install izy521/discord.io

    Example

    var Discord = require('discord.io');
     
    var bot = new Discord.Client({
        token: "",
        autorun: true
    });
     
    bot.on('ready', function() {
        console.log('Logged in as %s - %s\n', bot.username, bot.id);
    });
     
    bot.on('message', function(user, userID, channelID, message, event) {
        if (message === "ping") {
            bot.sendMessage({
                to: channelID,
                message: "pong"
            });
        }
    });

    Install

    npm i discord.io

    DownloadsWeekly Downloads

    566

    Version

    2.5.3

    License

    MIT

    Last publish

    Collaborators

    • izy521
    • lcookie