dictionary-nl
TypeScript icon, indicating that this package has built-in type declarations

2.0.0 • Public • Published

dictionary-nl

Dutch spelling dictionary.

Contents

What is this?

This is a Dutch dictionary, generated by wooorm/dictionaries from OpenTaal/opentaal-hunspell, normalized and packaged so that it can be installed and used like other dictionaries.

When should I use this?

You can use this package when integrating with tools that perform spell checking (such as nodehun or nspell) or when making such tools.

Install

This package is ESM only. In Node.js (version 16+), install with npm:

npm install dictionary-nl

Use

import nl from 'dictionary-nl'

console.log(nl)
// To do: use `nl` somehow

Yields:

{aff: <Buffer>, dic: <Buffer>}

API

This package exports no identifiers. The default export is a Dictionary.

It exports the TypeScript type Dictionary.

Dictionary

Hunspell dictionary.

Fields
  • aff (Buffer) — data for the affix file (defines the language, keyboard, flags, and more)
  • dic (Buffer) — data for the dictionary file (contains words and flags applying to those words)

Examples

See the monorepo readme for examples.

Compatibility

This projects is compatible with maintained versions of Node.js.

When we cut a new major release, we drop support for unmaintained versions of Node. This means we try to keep the current release line, compatible with Node.js 12.

Security

This package is safe.

Contribute

See the monorepo readme for how to contribute.

👉 Note: dictionaries are not maintained here. Report spelling problems upstream (OpenTaal/opentaal-hunspell).

License

Dictionary and affix file: (BSD-3-Clause OR CC-BY-3.0). Rest: MIT © Titus Wormer.

Package Sidebar

Install

npm i dictionary-nl

Weekly Downloads

1,617

Version

2.0.0

License

(BSD-3-Clause OR CC-BY-3.0)

Unpacked Size

2.57 MB

Total Files

7

Last publish

Collaborators

  • wooorm