Learn about our RFC process, Open RFC meetings & more.Join in the discussion! »

dictionary-hy

1.0.1 • Public • Published

dictionary-hy

Armenian spelling dictionary in UTF-8.

Useful with hunspell, nodehun, nspell, Open Office, LibreOffice, Firefox and Thunderbird, or macOS.

Generated by dictionaries from araktransfer.

Install

npm:

npm install dictionary-hy

Use

var hy = require('dictionary-hy')
 
hy(function (err, result) {
  console.log(err || result)
})

Yields:

{dic: <Buffer>, aff: <Buffer>}

Where dic is a Buffer for the dictionary file at index.dic (in UTF-8) and aff is a Buffer for the affix file at index.aff (in UTF-8).

Or directly load the files, using something like:

var path = require('path')
var base = require.resolve('dictionary-hy')
 
fs.readFileSync(path.join(base, 'index.dic'), 'utf-8')
fs.readFileSync(path.join(base, 'index.aff'), 'utf-8')

License

Dictionary and affix file: (GPL-2.0 OR LGPL-2.1 OR MPL-1.1). Rest: MIT © Titus Wormer.

Install

npm i dictionary-hy

DownloadsWeekly Downloads

1

Version

1.0.1

License

(GPL-2.0 OR LGPL-2.1 OR MPL-1.1)

Unpacked Size

2.24 MB

Total Files

6

Last publish

Collaborators

  • avatar