This package has been deprecated

Author message:

Just use `util.isDeepStrictEqual()`. It has been available since Node.js 10.

deep-strict-equal

0.3.0 • Public • Published

This package is deprecated as it's too much effort to keep it in sync with the Node.js implementation.


deep-strict-equal

Test for deep equality - Node.js assert.deepStrictEqual() algorithm as a standalone module

Issues and improvements should be done in Node.js first.

Install

$ npm install --save deep-strict-equal

Usage

const deepStrictEqual = require('deep-strict-equal');

deepStrictEqual({foo: {bar: [1, 2]}}, {foo: {bar: [1, 2]}});
//=> true

deepStrictEqual({foo: {bar: [1, 2]}}, {foo: {bar: [1, 4]}});
//=> false

deepStrictEqual({foo: {bar: 1}}, {foo: {bar: 1}});
//=> true

deepStrictEqual({foo: {bar: 1}}, {foo: {bar: '1'}});
//=> false

License

MIT © Sindre Sorhus

Package Sidebar

Install

npm i deep-strict-equal

Weekly Downloads

136,037

Version

0.3.0

License

MIT

Unpacked Size

2.92 kB

Total Files

4

Last publish

Collaborators

  • sindresorhus