node package manager
Stop writing boring code. Discover, share, and reuse within your team. Create a free org ยป

cordova-plugin-compat

cordova-plugin-compat

This repo is for remaining backwards compatible with previous versions of Cordova.

Deprecated

This plugin is no longer being worked on as the functionality provided by this plugin is now included in cordova-android 6.3.0. You should upgrade your application to use version 1.2.0 of this plugin. It will detect whether or not the plugin is required based on the version of cordova-android your app uses.

USAGE

Your plugin can depend on this plugin and use it to handle the new run time permissions Android 6.0.0 (cordova-android 5.0.0) introduced.

View this commit to see how to depend on cordova-plugin-compat. View this file to see how PermissionHelper is being used to request and store permissions. Read more about Android permissions at http://cordova.apache.org/docs/en/latest/guide/platforms/android/plugin.html#android-permissions.